Home > Eclipse, Misc > Eclipse Error: Failed to load the JNI shared library … \jre\bin\client\jvm.dll

Eclipse Error: Failed to load the JNI shared library … \jre\bin\client\jvm.dll

I tried to start a fresh downloaded Eclipse IDE (eclipse-SDK-4.2.2-win32-x86_64.zip) and got the following message:
Failed to load the JNI shared library “C:\Program Files (x86)\Java\jdk1.7.0_06\bin\..\jre\bin\client\jvm.dll”.

2013-05-29 18_02_09-Edit Post ‹ Chris's little Blog — WordPress

Check if you use a 64bit JDK to start the 64bit Eclipse. The 64bit JDK should be in “C:\Program Files\Java\..”

You can specify a specific JVM in the eclipse.ini file with the -vm argument:
-vm
C:\Program Files\Java\jdk1.7.0_21\bin\javaw.exe

The -vm option must occur before the -vmargs option, since everything after -vmargs is passed directly to the JVM.

Advertisements
Categories: Eclipse, Misc
  1. November 6, 2013 at 10:49

    very good article…. the -vm before the -vmargs help very much… thanks… 🙂

  2. Arif
    November 6, 2013 at 21:56

    Thanks it worked for me

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: