Home > Android, Development > WARNING: Application does not specify an API level requirement!

WARNING: Application does not specify an API level requirement!

You have to add the following line in your manifest:

<uses-sdk android:minSdkVersion=”8″ />

The following table specifies the API Level supported by each version of the Android platform.

Platform Version API Level
Android 4.1.1

Android 4.1

16
Android 4.0.4

Android 4.0.3

15
Android 4.0.2

Android 4.0.1

Android 4.0

14
Android 3.2 13
Android 3.1.x 12
Android 3.0.x 11
Android 2.3.4

Android 2.3.3

10
Android 2.3.2

Android 2.3.1

Android 2.3

9
Android 2.2.x 8
Android 2.1.x 7
Android 2.0.1 6
Android 2.0 5
Android 1.6 4
Android 1.5 3
Android 1.1 2
Android 1.0 1

For more informations have a look at http://developer.android.com/guide/appendix/api-levels.html.

Advertisements
Categories: Android, Development
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: